Server Settings for XenForo

Welcome To Extralicense, Forum Promotion, SEO, Domain Names, Hosting & More!

Buy, sell trade your licenses,Connect with fellow webmasters. Grow your network. Learn and share with us!

WenM

CuteXen Designs
Valued Member
Jun 25, 2011
94
38
Ok, I'd like some advice on my server specs, and whether they are suitable for XenForo:

here they are:

Code:
PHP  *
Current PHP version: 5.3.8
* safe_mode = OFF * memory_limit = 80MB
* upload_max_filesize = 12MB
* post_max_size = 12MB
* max_execution_time = 50 sec
* For image processing we offer GD2, but not ImageMagick.

Be aware that you cannot change the PHP configuration, except for register_globals and display_errors which are deactivated per default, but can be activated in the control panel.

MySQL *
MySQL version: 5.0.51a
* max_user_connections = 24
* max_allowed_packet = 16 MB
please give me your opinions. Thanks! ;)

 

Dan

Well-known member
Valued Member
Nov 13, 2019
1,791
540
Off the top of my head, everything looks ok to me. The only requirement that I don't see is MySQLi . notice the "i" on the end of MySQL. To be certain, you can download and run the requirements test script from http://xenforo.com/purchase/

 

Dan

Well-known member
Valued Member
Nov 13, 2019
1,791
540
MySQLi is a requirement.

  • PHP extensions: MySQLi, GD (with JPEG support), PCRE, SPL, SimpleXML, DOM, JSON, iconv, ctype
  • PHP safe_mode off

 

Dan

Well-known member
Valued Member
Nov 13, 2019
1,791
540
MySQLi is the new and improved driver for MySQL allowing you and your script to take advantage of the new features in MySQl 5.0+

Xenforo uses these new functions in MySQL extensively, hence the requirement.

 

WenM

CuteXen Designs
Valued Member
Jun 25, 2011
94
38
setting up on another server, and looks fine with Test script:

XenForo 1.0 System Requirements Test

Requirements Met

Your server meets all of XenForo's PHP requirements.
just hoping the other specs work fine, but it's only for test purposes at this time!

 
  • Like
Reactions: Dan

WenM

CuteXen Designs
Valued Member
Jun 25, 2011
94
38
just thinking about the other values like:

* max_execution_time = 50 sec

* max_user_connections = 24

seems a little low...what do you think? Just hope there's no max_execution_time errors when installing... waiting for 1.1!

 

Dan

Well-known member
Valued Member
Nov 13, 2019
1,791
540
just thinking about the other values like:
* max_execution_time = 50 sec

* max_user_connections = 24

seems a little low...what do you think? Just hope there's no max_execution_time errors when installing... waiting for 1.1!
My Max_execution_time is 30 seconds so I think you will be fine there. Don't remember what max connections is off the top of my head, but I think you are in good shape.

 
Top